Enable MPLS BGP forwarding.
mpls bgp forwarding
Configure pools.
ip pool vrf1-pool 51.52.53.0 255.255.255.0 private 0 vrf vrf1
exit
ip pool vrf2-pool 51.52.53.0 255.255.255.0 private 0 vrf vrf2
exit
ipv6 pool vrf2-v6pool prefix 2005:0101::/32 private 0 vrf vrf2
exit
ipv6 pool vrf3-v6pool prefix 2005:0101::/32 private 0 vrf vrf3
exit
Configure interfaces.
interface ce_interface_to_rtr
ip address 192.168.110.90 255.255.255.0
exit
interface ce_v6_interface
ip address 2009:0101:0101:0101::1/96
exit
interface ce_loopback loopback
ip address 52.1.2.3 255.255.255.255
exit
interface vrf1-loop loopback
ip vrf forwarding vrf1
ip address 1.52.53.54 255.255.255.255
exit
interface vrf2-loop loopback
ip vrf forwarding vrf2
ip address 2.52.53.54 255.255.255.255
exit
interface vrf2-v6loop loopback
ip vrf forwarding vrf2
ip address 2005:0202:0101::1/128
exit
interface vrf3-v6loop loopback
ip vrf forwarding vrf3
ip address 2005:0303:0101::1/128
exit
Configure BGP along with address families and redistribution rules.
router bgp 800
router-id 1.1.1.1
neighbor 192.168.110.20 remote-as 1003
neighbor 192.168.110.20 activate
address-family vpnv4
neighbor 192.168.110.20 activate
neighbor 192.168.110.20 send-community both
exit
address-family vpnv6
neighbor 192.168.110.20 activate
neighbor 192.168.110.20 send-community both
exit
ip vrf vrf1
route-distinguisher 800 1
route-target export 800 1
route-target import 800 1
exit
address-family ipv4 vrf vrf1
redistribute connected
redistribute static
exit
ip vrf vrf2
route-distinguisher 800 2
route-target export 800 2
route-target import 800 2
exit
address-family ipv4 vrf vrf2
redistribute connected
redistribute static
ASR 5500 System Administration Guide, StarOS Release 21.5
245
BGP MPLS VPNs
Sample Configuration
Содержание ASR 5500
Страница 100: ...ASR 5500 System Administration Guide StarOS Release 21 5 74 System Interfaces and Ports VLANs and Management Ports ...
Страница 136: ...ASR 5500 System Administration Guide StarOS Release 21 5 110 Smart Licensing Smart Licensing Bulk Statistics ...
Страница 140: ...ASR 5500 System Administration Guide StarOS Release 21 5 114 Monitoring the System Clearing Statistics and Counters ...
Страница 260: ...ASR 5500 System Administration Guide StarOS Release 21 5 234 Routing Viewing Routing Information ...
Страница 278: ...ASR 5500 System Administration Guide StarOS Release 21 5 252 BGP MPLS VPNs VPN Related CLI Commands ...
Страница 292: ...ASR 5500 System Administration Guide StarOS Release 21 5 266 Session Recovery Sample Output for show rct stats verbose ...
Страница 324: ...ASR 5500 System Administration Guide StarOS Release 21 5 298 Interchassis Session Recovery Fallback Procedure ...
Страница 338: ...ASR 5500 System Administration Guide StarOS Release 21 5 312 Engineering Rules ECMP Groups ...
Страница 362: ...ASR 5500 System Administration Guide StarOS Release 21 5 336 StarOS Tasks Management Processes ...