Example of Permitting All Packets from a Specified Host
In this first example, TCP packets from host 10.1.1.1 with TCP destination port equal to 24 are permitted. All others are denied.
Dell(conf)#ip access-list extended ABC
Dell(conf-ext-nacl)#permit tcp host 10.1.1.1 any eq 24
Dell(conf-ext-nacl)#
deny ip any any fragment
Dell(conf-ext-nacl)
Example of Permitting Only First Fragments and Non-Fragmented Packets from a Specified Host
In the following example, the TCP packets that are first fragments or non-fragmented from host 10.1.1.1 with TCP destination port equal to
24 are permitted. Additionally, all TCP non-first fragments from host 10.1.1.1 are permitted. All other IP packets that are non-first fragments
are denied.
Dell(conf)#ip access-list extended ABC
Dell(conf-ext-nacl)#permit tcp host 10.1.1.1 any eq 24
Dell(conf-ext-nacl)#permit tcp host 10.1.1.1 any fragment
Dell(conf-ext-nacl)#
deny ip any any fragment
Dell(conf-ext-nacl)
Example of Logging Denied Packets
To log all the packets denied and to override the implicit deny rule and the implicit permit rule for TCP/ UDP fragments, use a configuration
similar to the following.
Dell(conf)#ip access-list extended ABC
Dell(conf-ext-nacl)#permit tcp any any fragment
Dell(conf-ext-nacl)#permit udp any any fragment
Dell(conf-ext-nacl)#
deny ip any any log
Dell(conf-ext-nacl)
When configuring ACLs with the fragments keyword, be aware of the following.
When an ACL filters packets, it looks at the fragment offset (FO) to determine whether it is a fragment.
•
FO = 0 means it is either the first fragment or the packet is a non-fragment.
•
FO > 0 means it is dealing with the fragments of the original packet.
Configure a Standard IP ACL
To configure an ACL, use commands in IP ACCESS LIST mode and INTERFACE mode.
For a complete list of all the commands related to IP ACLs, refer to the
Dell Networking OS Command Line Interface Reference Guide
. To
set up extended ACLs, refer to
A standard IP ACL uses the source IP address as its match criterion.
1
Enter IP ACCESS LIST mode by naming a standard IP access list.
CONFIGURATION mode
ip access-list standard
access-listname
2
Configure a drop or forward filter.
CONFIG-STD-NACL mode
seq
sequence-number
{deny | permit} {
source
[
mask
] | any | host
ip-address
} [count [byte]
[dscp] [order] [monitor [
session-id
]] [fragments]
NOTE:
When assigning sequence numbers to filters, keep in mind that you might need to insert a new filter. To prevent
reconfiguring multiple filters, assign sequence numbers in multiples of five.
To view the rules of a particular ACL configured on a particular interface, use the
show ip accounting access-list
ACL-name
interface
interface
command in EXEC Privilege mode.
118
Access Control Lists (ACLs)
Содержание S3048-ON
Страница 1: ...Dell Configuration Guide for the S3048 ON System 9 11 2 5 ...
Страница 137: ...0 Gi 1 1 Gi 1 2 rx Flow N A N A 0 0 No N A N A yes Access Control Lists ACLs 137 ...
Страница 142: ...Figure 10 BFD Three Way Handshake State Changes 142 Bidirectional Forwarding Detection BFD ...
Страница 241: ...Dell Control Plane Policing CoPP 241 ...
Страница 287: ... RPM Synchronization GARP VLAN Registration Protocol GVRP 287 ...
Страница 428: ...Figure 53 Inspecting the LAG Configuration 428 Link Aggregation Control Protocol LACP ...
Страница 429: ...Figure 54 Inspecting Configuration of LAG 10 on ALPHA Link Aggregation Control Protocol LACP 429 ...
Страница 432: ...Figure 56 Inspecting a LAG Port on BRAVO Using the show interface Command 432 Link Aggregation Control Protocol LACP ...
Страница 433: ...Figure 57 Inspecting LAG 10 Using the show interfaces port channel Command Link Aggregation Control Protocol LACP 433 ...
Страница 477: ...Figure 73 Configuring Interfaces for MSDP Multicast Source Discovery Protocol MSDP 477 ...
Страница 478: ...Figure 74 Configuring OSPF and BGP for MSDP 478 Multicast Source Discovery Protocol MSDP ...
Страница 479: ...Figure 75 Configuring PIM in Multiple Routing Domains Multicast Source Discovery Protocol MSDP 479 ...
Страница 483: ...Figure 77 MSDP Default Peer Scenario 2 Multicast Source Discovery Protocol MSDP 483 ...
Страница 484: ...Figure 78 MSDP Default Peer Scenario 3 484 Multicast Source Discovery Protocol MSDP ...
Страница 634: ...protocol spanning tree pvst no disable vlan 300 bridge priority 4096 634 Per VLAN Spanning Tree Plus PVST ...
Страница 745: ...Figure 104 Single and Double Tag TPID Match Service Provider Bridging 745 ...
Страница 746: ...Figure 105 Single and Double Tag First byte TPID Match 746 Service Provider Bridging ...