Examples: Classifying, Policing, and Marking Traffic on Physical Ports Using Policy Maps
This example shows how to create a policy map and attach it to an ingress port. In the configuration, the IP
standard ACL permits traffic from network 10.1.0.0. For traffic matching this classification, the DSCP value
in the incoming packet is trusted. If the matched traffic exceeds an average traffic rate of 48000 b/s and a
normal burst size of 8000 bytes, its DSCP is marked down (based on the policed-DSCP map) and sent:
Switch(config)#
access-list 1 permit 10.1.0.0 0.0.255.255
Switch(config)#
class-map ipclass1
Switch(config-cmap)#
match access-group 1
Switch(config-cmap)#
exit
Switch(config)#
policy-map flow1t
Switch(config-pmap)#
class ipclass1
Switch(config-pmap-c)#
trust dscp
Switch(config-pmap-c)#
police 1000000 8000 exceed-action policed-dscp-transmit
Switch(config-pmap-c)#
exit
Switch(config-pmap)#
exit
Switch(config)#
interface gigabitethernet2/0/1
Switch(config-if)#
service-policy input flow1t
This example shows how to create a Layer 2 MAC ACL with two permit statements and attach it to an ingress
port. The first permit statement allows traffic from the host with MAC address 0001.0000.0001 destined for
the host with MAC address 0002.0000.0001. The second permit statement allows only Ethertype XNS-IDP
traffic from the host with MAC address 0001.0000.0002 destined for the host with MAC address
0002.0000.0002.
Switch(config)#
mac access-list extended maclist1
Switch(config-ext-mac)#
permit 0001.0000.0001 0.0.0 0002.0000.0001 0.0.0
Switch(config-ext-mac)#
permit 0001.0000.0002 0.0.0 0002.0000.0002 0.0.0 xns-idp
Switch(config-ext-mac)#
exit
Switch(config)#
mac access-list extended maclist2
Switch(config-ext-mac)#
permit 0001.0000.0003 0.0.0 0002.0000.0003 0.0.0
Switch(config-ext-mac)#
permit 0001.0000.0004 0.0.0 0002.0000.0004 0.0.0 aarp
Switch(config-ext-mac)#
exit
Switch(config)#
class-map macclass1
Switch(config-cmap)#
match access-group maclist1
Switch(config-cmap)#
exit
Switch(config)#
policy-map macpolicy1
Switch(config-pmap)#
class macclass1
Switch(config-pmap-c)#
set dscp 63
Switch(config-pmap-c)#
exit
Switch(config-pmap)#
class macclass2 maclist2
Switch(config-pmap-c)#
set dscp 45
Switch(config-pmap-c)#
exit
Switch(config-pmap)#
exit
Switch(config)#
interface gigabitethernet1/0/1
Switch(config-if)#
mls qos trust cos
Switch(config-if)#
service-policy input macpolicy1
This example shows how to create a class map that applies to both IPv4 and IPv6 traffic with the default class
applied to unclassified traffic:
Switch(config)#
ip access-list 101 permit ip any any
Switch(config)#
ipv6 access-list ipv6-any permit ip any any
Switch(config)#
class-map cm-1
Switch(config-cmap)#
match access-group 101
Switch(config-cmap)#
exit
Switch(config)#
class-map cm-2
Switch(config-cmap)#
match access-group name ipv6-any
Switch(config-cmap)#
exit
Switch(config)#
policy-map pm1
Switch(config-pmap)#
class cm-1
Switch(config-pmap-c)#
set dscp 4
Consolidated Platform Configuration Guide, Cisco IOS Release 15.2(4)E (Catalyst 2960-X Switches)
634
Configuration Examples for QoS
Содержание Catalyst 2960 Series
Страница 78: ...Consolidated Platform Configuration Guide Cisco IOS Release 15 2 4 E Catalyst 2960 X Switches lxxviii Contents ...
Страница 96: ......
Страница 184: ...Consolidated Platform Configuration Guide Cisco IOS Release 15 2 4 E Catalyst 2960 X Switches 102 Additional References ...
Страница 195: ...P A R T II IP Multicast Routing Configuring IGMP Snooping and Multicast VLAN Registration page 115 ...
Страница 196: ......
Страница 250: ......
Страница 292: ......
Страница 488: ......
Страница 589: ...P A R T VI Cisco Flexible NetFlow Configuring NetFlow Lite page 509 ...
Страница 590: ......
Страница 619: ...P A R T VII QoS Configuring QoS page 539 Configuring Auto QoS page 645 ...
Страница 620: ......
Страница 749: ...P A R T VIII Routing Configuring IP Unicast Routing page 669 Configuring IPv6 First Hop Security page 677 ...
Страница 750: ......
Страница 796: ...Consolidated Platform Configuration Guide Cisco IOS Release 15 2 4 E Catalyst 2960 X Switches 714 Additional References ...
Страница 856: ...Consolidated Platform Configuration Guide Cisco IOS Release 15 2 4 E Catalyst 2960 X Switches 774 Additional References ...
Страница 1400: ...Consolidated Platform Configuration Guide Cisco IOS Release 15 2 4 E Catalyst 2960 X Switches 1318 Additional References ...
Страница 1546: ...Consolidated Platform Configuration Guide Cisco IOS Release 15 2 4 E Catalyst 2960 X Switches 1464 Auto Identity ...
Страница 1596: ...Consolidated Platform Configuration Guide Cisco IOS Release 15 2 4 E Catalyst 2960 X Switches 1514 Additional References ...
Страница 1604: ......
Страница 1740: ......
Страница 1764: ...Consolidated Platform Configuration Guide Cisco IOS Release 15 2 4 E Catalyst 2960 X Switches 1682 Additional References ...
Страница 1942: ...Consolidated Platform Configuration Guide Cisco IOS Release 15 2 4 E Catalyst 2960 X Switches 1860 cli_write ...
Страница 1950: ...Consolidated Platform Configuration Guide Cisco IOS Release 15 2 4 E Catalyst 2960 X Switches 1868 context_save ...
Страница 2058: ...Consolidated Platform Configuration Guide Cisco IOS Release 15 2 4 E Catalyst 2960 X Switches 1976 event_register_wdsysmon ...
Страница 2076: ...Consolidated Platform Configuration Guide Cisco IOS Release 15 2 4 E Catalyst 2960 X Switches 1994 smtp_subst ...
Страница 2090: ...Consolidated Platform Configuration Guide Cisco IOS Release 15 2 4 E Catalyst 2960 X Switches 2008 sys_reqinfo_syslog_history ...
Страница 2104: ...Consolidated Platform Configuration Guide Cisco IOS Release 15 2 4 E Catalyst 2960 X Switches 2022 unregister_counter ...
Страница 2105: ...P A R T XII Configuring Cisco IOS IP SLAs Configuring Cisco IP SLAs page 2025 ...
Страница 2106: ......
Страница 2118: ......
Страница 2164: ......