35-6
Catalyst 4500 Series Switch, Cisco IOS Software Configuration Guide - Cisco IOS XE 3.9.xE and IOS 15.2(5)Ex
Chapter 35 Configuring Layer 3 Interfaces
Configuring Logical Layer 3 GRE Tunnel Interfaces
Configuring Logical Layer 3 GRE Tunnel Interfaces
Generic Routing Encapsulation (GRE) is a tunneling protocol used to encapsulate network layer
protocols inside virtual point-to-point links. A GRE tunnel only provides encapsulation and not
encryption.
Note
Beginning in Cisco IOS XE Release 3.7.1E, GRE tunnels are supported on the hardware on
Catalyst 4500 series switches.
When GRE is configured without tunnel options, packets are hardware-switched. When GRE is
configured with tunnel options (such as key, checksum, etc.), packets are switched in the software.
Multicast routing is not supported on GRE tunnels, so PIM configuration is not supported on a GRE
tunnel interface.
To configure a GRE tunnel, perform this task:
This example shows how to configure the logical Layer 3 GRE tunnel interface tunnel 2:
Switch>
enable
Switch#
config term
Switch(config)#
interface tunnel 2
Switch(config-if)#
ipv6 address 1001:1::1/64
Switch(config-if)#
ip address 100.1.1.1 255.255.255.0
Switch(config-if)#
tunnel source 10.10.10.1
Switch(config-if)#
tunnel destination 10.10.10.2
Switch(config-if)#
tunnel mode gre ip
Switch(config-if)#
end
Configuring Logical Layer 3 VLAN Interfaces
Note
Before you can configure logical Layer 3 VLAN interfaces, you must create and configure the VLANs
on the switch, assign VLAN membership to the Layer 2 interfaces, enable IP routing if IP routing is
disabled, and specify an IP routing protocol.
Command
Purpose
Step 1
Switch(config)#
interface tunnel
number
Enables tunneling on the interface.
Step 2
Switch(config-if)#
ipv6 address
ip_address
subnet_mask
Configures the IPv6 address and subnet mask.
Step 3
Switch(config-if)#
ip address
ip_address
subnet_mask
Configures the IP address and IP subnet.
Step 4
Switch(config-if)#
tunnel source
{ip-address | type
number}
Configures the tunnel source.
Step 5
Switch(config-if)#
tunnel destination
{hostname |
ip-address}
Configures the tunnel destination.
Step 6
Switch(config-if)#
tunnel mode gre ip
Configures the tunnel mode.
Step 7
Switch(config-if)#
end
Exits configuration mode.
Step 8
Switch#
copy running-config startup-config
Saves your configuration changes to NVRAM.
Step 9
Switch#
show running-config interface tunnel
number
Verifies the configuration.
Summary of Contents for Catalyst 4500 Series
Page 2: ......
Page 4: ......
Page 2086: ...Index IN 46 Software Configuration Guide Release IOS XE 3 9 0E and IOS 15 2 5 E ...